Statuspage: Temporal Cloud sustained outage

Incident Report for FasterOutcomes

Resolved

Monitoring detected recovery. Automated resolution by Statuspage bridge.
Posted Jul 16, 2026 - 23:27 EDT

Investigating

Check passed for backend-prod-429012 Uptime Check URL labels {project_id=backend-prod-429012, host=status.temporal.io} with metric labels {check_id=statuspage-status-temporal-io-api-v2-status-json-q289tT90rqw} is below the threshold of 0.500 with a value of 0.000.

GCP incident: https://console.cloud.google.com/monitoring/alerting/alerts/0.oabkp0w4116f?channelType=cloud-pubsub&project=backend-prod-429012
Posted Jul 16, 2026 - 18:37 EDT
This incident affected: Temporal Cloud.